Skip to content
Navigation Menu Blog v2
Unser IT Blog
Bleiben Sie auf dem Laufenden und erhalten Sie neue Impulse.
01-Citrix-NetScaler-Health-Check
06.20242 min Lesezeit

NetScaler 13.0 EOL und die Migration auf Advanced Policies

Mit dem 15. Juli 2024 steht das End of Life der Citrix NetScaler Version 13.0 vor der Tür. Mit dem End of Life endet der Herstellersupport für das Produkt und es werden keine neuen (Sicherheits-) Updates veröffentlich.

NetScaler-EOL-Versionsnummer-prüfen (1)Wie prüfe ich die NetScaler-Version?

Um herauszufinden, welche NetScaler-Version Sie haben, klicken Sie oben rechts auf den Usernamen. Dann öffnet sich ein Menü mit der Version.

 

Sie setzen in Ihrer NetScaler-Umgebung noch auf Classic Policies?

Beachten Sie bei dem notwendigen Upgrade auf NetScaler Version 13.1:

Bereits mit Veröffentlichung der Version 12.0 (Build 56.20) hat Citrix die Classic Policies für veraltet erklärt. Dennoch wurden diese bislang weiterhin unterstützt. Durch das Upgrade auf Version 13.1 wird nun ein Teil der Ausdrücke der Classic Policies entfernt und kann nicht mehr weiterverwendet werden.

Es handelt sich dabei um:

  • Sure Connect (SC),
  • Priority Queuing (PQ),
  • HTTP Denial of Service (HDoSP) und
  • HTML Injection.

Die nachfolgenden Ausdrücke werden zwar weiterhin unterstützt, stehen allerdings als veraltet ebenfalls bereits auf der Abschussliste für zukünftige Releases: 

  • Syslog
  • Nslog
  • Client security expressions
  • Traffic Management SessionPolicy
  • File based expressions
  • Authentication
  • Traffic Management SessionPolicy
  • Authorization
  • VPN

 

Übersicht zur Policy Migration

NetScaler-Policy-Migration-Übersicht (1)

Bildquelle: Citrix

So nutzen Sie Citrix NSPEPI zur Umstellung von Classic auf Advanced Policies

Für die Konvertierung eines Teils der Classic Policies stellt Citrix das Tool NSPEPI zu Verfügung. Mit diesem Tool lassen sich einzelne Ausdrücke von Hand anpassen – oder Sie wenden es auf Ihre gesamte Konfiguration „ns.conf“ an. 

Einige Basic Policies bringen verschiedene Voraussetzung für die Umstellung auf Advanced Policies mit sich: Für die Umstellung Ihrer Basic Auth Policies muss beispielsweise zuvor nFactor zur Authentifizierung implementiert werden. 

Des Weiteren erfolgt die Konvertierung mittels NSPEPI natürlich 1:1 und erzeugt lediglich aktualisierte Files. Um die Vorteile und die bessere Performance der Advanced Syntax vollständig nutzen zu können, ist weiterhin eine manuelle Anpassung nötig und im Anschluss an die Umstellung empfohlen. 

Sollten Sie Interesse an einer Beurteilung und/oder Optimierung Ihrer bestehenden Konfiguration haben, sprechen Sie uns gerne an. 

Weiterführende Informationen finden Sie bei Citrix unter den folgenden Links: 

NetScaler ADC Firmware Release Cycle 

NetScaler Release Notes 

NetScaler Notice of Status Change for Classic Policy Based Features 

Handeln Sie jetzt und upgraden Sie auf die aktuelle Version 13.1. Ein Upgrade auf Version 14.1 wird von uns nicht empfohlen, da sich diese derzeit noch in der Feature-Phase befindet. 

Sie haben Fragen oder benötigen Unterstützung bei der Durchführung des Upgrades? Ihr Wartungsvertrag ist ausgelaufen oder Sie benötigen eine Subskription Verlängerung oder Informationen zum neuen Lizenzmodell?

Sprechen Sie uns an! 

Unser Vertriebsteam und unsere Techniker stehen Ihnen mit Rat und Tat zur Seite. 

avatar

Patrick Goldfuss

IT-Consultant
…meine über 15-jährige Erfahrung im Umfeld von (virtualisierten) Server- und Storagesystemen bringe ich gerne bestmöglich in Ihre Konzept- und Projektarbeiten ein.

KOMMENTARE